How to manually clean up all I-Novae installation files and start fresh

#1

A recent patch for the installation runtime can cause package corruption under certain circumstances. If your installation package gets corrupted the only way to fix that at the moment is to manually delete your installation.

  1. The installation runtime maintains a “registry” of all I-Novae related installations. It does this to keep track of installation state for various components, versioning, etc. You will need to delete this. The I-Novae Installer itself is always installed for “everyone”. That means its registry entries, along with everything else installed for “everyone”, are located at C:\Program Files\INovaeInstallerRegistry. If you installed the I-Novae Launcher or the game for “Just Me” then it will be located at %localappdata%. This is a valid path if you enter it into the address bar of Windows/File Explorer. Lastly, the INovaeInstallerRegistry directory is hidden. You will need to have “view hidden folders/files” enabled in your Windows/File Explorer to see it. It’s hidden because, under normal circumstances, you should not mess with it.
  2. Inside the INovaeInstallerRegistry\Products directory you will see directories named 0, 1, and 2. 0 is the I-Novae Installation Runtime, 1 is the I-Novae Launcher, and 2 is Infinity: Battlescape. You will need to delete the numbered directory for whichever application you are having a problem. For example, if the installation for the I-Novae Launcher (id 1) is corrupted you will need to delete INovaeInstallerRegistry\Products\1. DO NOT DELETE THE WRONG DIRECTORY.
  3. Now that you’ve deleted the registry entries for the installation you need to delete the installation itself. Using the I-Novae Launcher as an example, its default installation location for “everyone” is C:\Program Files\I-Novae Studios\Launcher - delete that directory. For a “Just Me” installation it will, by default, be at %localappdata%\I-Novae Studios\Launcher. If you changed the installation location then you need to delete whatever directory you put it in.
  4. You should now be all set. Go back to the Infinity: Battlescape website, download INovaeInstaller.exe, and reinstall everything.

If you’re reading this because you have a problem we’re terribly sorry for the inconvenience and we appreciate your patience. If you run into any additional problems or have questions please don’t hesitate to let us know.

5 Likes
Failed to write temporary UI Executable
Installation Package Was Corrupt
Failed to load the installation package
pinned #2
#3

Thank you, I will get on that right away, hopefully meet you sometime in the black.

#4

https://inovaestudios.blob.core.windows.net/deployment/INovaeInstaller.exe to download the installer.

#5

This fix isn’t working for me. I did notice that after I installed I only get 1 in the product folder, and not 0 or 2.

Regardless, I tried to delete that 1 product folder and still get the same error that product 1 is corrupt when I reinstall.

#6

Have you re-downloaded INovaeInstaller.exe from the link above? You deleted the 0, 1, and 2 folders along with the primary installation directories inside of I-NovaeStudios\ (by default)?

#7

Hi Guys, I would firstly like to congratulate you on what is looking to be a GREAT gaming experience still in the making.

Unfortunately, I feel your installation and gaming client (steam wannabe) is a pile of Donkey Shit (and that’s an insult to donkeys)

I am an asteroid backer, trying to jump on this weekend, and have had nothing but issues to get the game running or simply do anything, including trying to uninstall the client.
Started with a patch update that simply fails, leading to trying to uninstall it, and then trying to remove everything and the launcher (to try and start the install process all over again) BUT nothing works.

Just constant errors that drop me back to the desktop.

Waste of 9GB on my internet.

Frustrated but hopefull fan.
ps. please stop making installations that force useless folders with your studios name in them. NO ONE CARES. That kind of developer forced advertising was an infestation in games back in the nineties.

1 Like
#8

It’s really weird how so many people are experiencing installation errors, I remember having similar issues a few patches ago that took a while to overcome.

I assume you’ve read Keith’s posts both in this thread and a couple of other recent ones about how to clean things up? Tracking down hidden folders is important when trying to reinstall or you’ll hit the same errors.

Could you be more specific about at one point during the installation you’ve had problems, and what the error was? It sounds like you are successfully running the launcher, and the problem is when you try to use the launcher to install the game?

Remember: it’s very important to manually delete all hidden folders related to I-Novae / Battlescape in order to start afresh, including anything in Program Files, Documents, and Temp.

#9

Just letting you know, updating from launcher 0.1.18.0 to 0.1.20.0. (Haven’t run the game in a couple of weeks)

I assume it’s the same error, so I will try the instructions here, but wanted to log that I also had an issue.


My reaction:

Wuh…
image

Wha…

image

WUH??
image

/Runs off to check forums.


My solution
I deleted the entire installation. Weirdly, I found folders in both Program Files and %localappdata%, which didn’t sound right considering your explanation of install locations. I wonder if I had a partial old installation left over and that could have contributed to the issue?
Anyway, got rid of everything in both locations, and my documents to be on the safe side. Then redownloaded the installer, which seems to have worked and the game is now reinstalling… We shall see!

1 Like
#10

Given that you’re a long-time player our early builds did have an issue where they accidentally left installation packages behind. This should not have contributed to the problem you experienced here, which was caused by a bug in the installation runtime released just before the Asteroid backer weekend.

#11

i posted already but i can download the installer but when i try to launch i get I-Novae Launcher Initialization Error every time. tried uninstalling the app data, program file and registry. still get the error.
also says failed to create user path etc. thanks!!

#12

@jasonmvt Are you getting Intialization Error when you try to login or when you’re trying to install the game? If it’s during installation could you send a copy of your installation logs to contact at inovaestudios.com, they should be located in your %temp% directory.

#13

yeah thanks for the response! i will email one over. it gives me the message during installation right when i click exit at the end of the process with run program box checked. and any time i try to run the shortcut.

#14

Thanks for the logs. Unfortunately there are no errors in either log file. Can you take a screen shot of the error? Are you getting the error while installing the I-Novae Launcher or while installing Infinity: Battlescape?

#15

It seems like Its after I download it, then on the final screen I exit with the box checked to run the program and then I get the error. Same error when I click the launcher shortcut. I can’t run the launcher basically. I will send a screen shot of the error when I get home from work. Thanks!!

#17

Capture

#18

On startup it tries to create a directory where it stores your user settings if it doesn’t already exist, in your case C:\Users\admin\Documents\I-Novae Launcher, and for some reason that process is failing. Since your username appears to be admin my guess is there could be some weird permissions thing going on. Did you install the launcher for “everyone”? If so, can you try uninstalling it and re-installing it selecting “Just for Me” and running it again? If you installed it as “Just for Me” please try the opposite, installing it for “everyone”.

#19

Ok, yeah, i tried both i believe. ill try again. tried it on 2 different drives even.

#20

One option is to just create the folder yourself. That won’t help me figure out what’s going on but it should solve your problem and let you continue (assuming there are no further issues, it will also try to create a separate directory in %temp% after that one).

#21

nevermind sorry i did it. that worked right away. thats weird that the folder isnt there…
thanks man youre awesome.

1 Like