How to manually clean up all I-Novae installation files and start fresh

The installer is pretty terrible, with the icing on the cake being that I’ve NEVER been able to read any of the log’s it’s ever written - Wordpad always says:

“The document (some long path with a massive hex number that you’ve got no hope of finding) is in use by another application and cannot be accessed.”

Aside from not failing to install do you have any suggestions we could use to improve the installation experience?

Also, have you tried opening the log files with notepad?

hello, the next free weekend the game worked perfectly but i wanted to try the game this new weekend but my installer is corrupted …i had this message : “the update is failed” and it was impossible to unistall it from Windows…. so i have a bad idea and i think i have done a wrong thing : i have delated all the directory named “inovae” in C: , progams files and localdata. now i can’t install the new installer. how can i do please !

Can you email your installation logs to contact at They’ll be located in %temp% and are named INovaeInstall_*.log.

ok, i will find it

here is my logfile :

(i can find your email so i put it on my Dropbox)
thanks in advance for your help !! :sunglasses:

Upgrading your installation runtime is failing, there will be a separate log file that will explain what happened. That being said the easiest way to fix the problem will be to follow the guide in the OP to delete C:\Program Files\INovaeInstallerRegistry\Products\0 and C:\Program Files\I-Novae Studios\Installer. Then re-download the installer from the Infinity: Battlescape website and run that.

1 Like

ok, i have found the good directory, in fact i didn’t show all the hidden files :wink:
i have find the 0, 1, 2 directories

yes, it works. thanks a lot !! sorry i am a beginner with window10. i have it since this year only, before i had windows7

Aside from not failing to install do you have any suggestions we could use to improve the installation experience?

It just seems an overly convoluted experience, with a large number of steps, unlike most games: First it has to install the Installer (why?!), then install the Launcher, then install the Game, and each of those has several stages (and it can fail at any of those points). But I wouldn’t mind all those steps so much, if they ‘just worked’.

It’s also a bit annoying that the Game installer doesn’t remember where the Launcher was installed, so you have to navigate to there again.

1 Like

Just butting in here! I’m sure it’s on your to-do list somewhere, but the game installation stage itself is not ready for the wider public. Where games have launchers, people expect it to download files in stages, meaning if you exit and reopen, it will carry on from where it got to. This also ties into expecting patches to not download the entire game every time.

Unless Steam integration is going to solve this problem, because Steam installs games this way anyway?


We haven’t been putting a whole lot of time into it precisely because Steam has its own system that does all of those things. Our system will eventually do those things as we’ll be using it for mods etc however modding is obviously a ways off. The primary goal of our distribution system was to solve a key problem we encountered immediately after the Kickstarter - we needed flexible access control built into our distribution system as we needed to be able to get the game and patches into the hands of a subset of our users while also being able to turn on/off different groups of users at a moment’s notice. While it hasn’t been without bumps in the road it has overall been a success in achieving that goal.


Hi I found the file error " C:\users\user\AppData\Local\INovaeInstallerRegistry\Products\1\PackageCache_0.1.18.0_.ind’for Product 1. " I hope this helps

1 Like

the 2 dashes are underscores.

What’s the error? That’s just the path to the package. Is the issue that it can’t load the package? Are you trying to upgrade an existing installation?

It’s best to jump into discord to get help.
It’s important to know for the devs what error code you ran into and what failed. You can send the log files to the devs, that way they can inspect what went wrong with your install.

I did a restart. It allowed me to delete. That was after a disk error on boot screen which was a scare. Lets see what happens from here. Slightly jaded buy still excited.

1 Like

If there was a process still running with active file access, then you can’t delete said file. I think that’s what happened. The installer logs would have been helpful for the devs. If it fails again please try and send them to contact @ inovaestudios dot com. @INovaeKeith wants to crush those bugs :slight_smile:

1 Like

We also install some dependencies including .NET and the Microsoft VC++ runtime. These sometimes require reboots, however our installer does not properly handle reboots at the moment as they’re incredibly difficult and time consuming to test - this may have been the source of your problem.