Alpha play-test week-end: issues or feedback

If you have any issue with the alpha play-test week-end, or want to post feedback, screenshots, share your experiences, or complain about bugs :wink: this is the topic !

See you all ( hopefully ) in game :slight_smile:

11 Likes

downloading… :slight_smile:
i’d suggest here to add a “Pause” button. so i could pause the dl when i had to shut down the PC or have to disconnect the internet for whatever reason, etc…

and maybe a dl-bitrate limiter, so i can limit the download speed for instance to 1 MB/s or sth…
steam has this too, and it’s useful for large downloads and people with limited bandwith…

Ok, not so important now, but maybe for release…

3 Likes

on that note: associate .ind files with the battlescape launcher and make it possible to install them by dragging them onto the launcher exe or double clicking.

1 Like

ok, the download was finished and i was asked for the path to install the game to.
i chose the path and clicked ok, but then the launcher told me that it could not install the game and i should view the log file.
i did that, and in the log file was sth. about “Error: [Elevated Child] Could not perform Install because the system needs to be rebooted.”

however, i closed the message and tried to install again.
And now it told me that the PC had to be restarted.

This is what i’ll do now.
The question is: why didn’t the installer tell me that right from the beginning? instead it showed me an error message which didn’t tell me anything useful until i tried to install it for a second time - then it told me the actual problem (restart required)

Support for reboot’s is still a work in progress unfortunately as it’s difficult for me to test since the computers used by the dev team are always up-to-date and therefore never require restarts. This means I have to spin up VM’s to test reboot except after the VM is rebooted the system is now in a state that no longer requires reboots so I have to rollback the VM. In other words, testing reboots is extremely difficult and time consuming. Did everything work properly after restarting your computer?

1 Like

I was just about to say:
“no, it didn’t work.! the installer progress bars are stuck at 0% and not moving at all. And although the game folder is created, there are only 0kb and 1kb files in the subfolders.”.

Then suddenly, like from one second to another, the installation was finished and i’m now in the launcher window with all the settings etc… :slight_smile:
So it seems that just the progress bars weren’t updated… i couldn’t move that launcher window around with my mouse, so i guess it was hanging in some way…

Yes, i see. It makes sense that systems differ, and some need to be rebooted while others don’t…

Thanks for the explanation.

I’m not sure if it helps, but here is the last part of the log that the error message told me to look at:

[Elevated Child] Running installation.
Error: [Elevated Child] Could not perform Install because the system needs to be rebooted.
Elevated Server: An empty packet was received, killing packet stream.
Elevated Server: Packet stream closing...
Error: Elevated child process exited with exit code 'InstallRejected (1654)'.
Elevated Server: Waiting for elevated process packet stream to close...
Elevated Server: Elevated process packet stream has closed.
Elevated installation server returning completion state 'InstallRejected'.
The InstallationProgressPage.InstallThreadMain() installation thread has succeeded with exit code 'InstallRejected'.

I can’t install as after i DL the installer it asks me to reboot. I reboot but nothing happened. Tried to instal again but same thing.

One other person has also run into this problem and it was being caused by their virus scanner. I’m working on implementing a fix though it probably won’t be ready for a few hours at least.

i only use built in win 10 protection, no 3rd party. i will turn defender off.

turning defender off did not help.

i also tried compatability settings to win 7 with administrator settings on.

Unable to install due to the reboot issue as well.
Turned avast shield and firewall off but no avail.
Guess ill ogle on discord with jealousy :slight_smile:

Had the same issue. Just start the launcher in administrator mode. After the installation fails because of the reboot error do a manual reboot. After rebooting start the launcher again in administrator mode, the game will then install properly. At least it did for me.

Sorry to say but the current balance is way unfun. You cant tell what ships NPCs fly until very close, takes ages to kill an interceptor cause they will mostly run away. Once you have a Corvette you can start farming small NPCs but often they are already dead and only NPC capships left around. Which pretty much insta gib your Corvette and you are broke again.

And something is off about hit detection - i dont remember it being that bad pre-gimbal. I only start doing damage under 500 m really. I even had a near static face to face hover shootout with a player interceptor and we both hardly hit - including seeing explosions and not hearing hit confirmation sound. Some hits would go through, but judging by the amount of hit sounds i heard he should have been long dead before he died. Likewise, he cant possibly have missed me that much when NPC salvoes can rip through you in seconds if you dont evade. Something is off and i cant tell what - i wish i had paid more attention to the engagement ranges i used for different ships in the last patch to compare. :frowning:

4 Likes

Playbenni that did not work.

I’ve had to reboot twice now trying to install the update. Now, when launching the I-Novae Studios Launcher I get the following error message. Running as admin does not change anything. Upon clicking “OK” I get taken to a login screen where it appears to have to connection to the servers to verify my login info. I’ve gone through all BitDefender options as well and granted it access, so I wouldn’t suspect that it would be causing the hang up.

Hi

The launcher is proposing to choose a controller device ( I have a warthog, a xbox pad, and a rudder ). Is this supposed to work, because my stick seems useless, which I can understand for a pre alpha :wink: , but the controller dropdown menu gave me some hope :stuck_out_tongue: .

There’s a handful of people experiencing this problem. I haven’t been able to figure out what’s going on yet. Do you have any special proxy settings or anything?

I’m trying to find information on how to use warp to approach a target. I figured out how to engage it and target something but the ship doesn’t slow down. What am I doing wrong? Is there documentation on how to approach a target?

During your approach, you can change your speed. Get close to your target, decrease your speed to something reasonable so you can actually see the object approaching, then drop out of warp right at the position you want to be in.