Weekly Update #12

We’re happy to announce that today we released patch v0.1.4.0 to all of our Developer Access backers. It contains numerous improvements and tweaks to the game. Most notably it has our new input mapper with support for gamepads and joysticks, a more realistic atmospheric flight model, the second iteration of the corvette, and most importantly the new interceptor! We’ve been getting some questions from Alpha backers about when the game will be available to play. The Alpha release is currently scheduled for October 29th, 2016.

(Mockup of the interceptor cockpit)

Over the next few weeks our engineering focus is going to shift from integrating ships and gameplay tweaks to taking care of some low level plumbing before we dive into weapons. Specifically we need to make some improvements to our core networking layer such as removing the last remnants of our trusted client code, which prevents hacking, and improving latency compensation. On top of that we still need to get our pledge upgrade system built for those of you who are looking to get in on the action sooner rather than later.

(Revision 2 of the corvette cockpit)

The art team’s primary focus will be on space stations, land bases, and factories. These are large, complicated assets that will take a lot of time to complete. They will also continue work on revising the bomber, interceptor, and corvette as needed based on playtesting feedback. Looking back, full development began on February 1st and in the 3 months since then we’re pretty happy with our progress. There’s a lot that still needs to be done for the Alpha but we’ve worked through the initial ramp-up and reached a good cadence.

(Revision 3 of the bomber)


Haven’t had a chance to try the corvette in 1.4 yet but the new cockpit on the pic looks much more awesome :smile: Less boxy!

Haven’t had the chance to try the old Corvette, but even the new one seemed very difficult to control. Could be related to the bug that I posted in the other thread (Lomsor’s 1.4.0 Patch thread)

Reposted to ED, SC, LTT, Guru3d.

My wallet is starting forest fires here D:

Btw, Can we get the corvette in red?

The last 3 months have been really productive! Stellar in my opinion. Keep the great work. :grinning:


Well, to almost all of them. :grin:

1 Like

@xamino you still can’t play?

I really like the fighter + that bomber… damn guys it looks lot better now.
You are great.

1 Like

Thunder Cats Woa.aoa.oah!

I just want to say that i think revision 3 of the Bomber is a really good improvement. Still not keen on Cockpit visibility, and still would love to see beefy Retro Trusters, but the reworked midsection has fixed its mayor design weak spot imho.

1 Like

peraps making it more pointy :smiley:


Dammit! Don’t give me false hope! D:

1 Like

That would give a lot better visibility and looks better as well.

Just realised what it was reminding me of…

Medusa, my precious!


Right, right ? It always reminded me of it only thing missing was the nose :wink:

actually now that I look at it, its more like Ares

1 Like

Nope, still get the same error.

Nobody mention the desktop background. It is there for a perfectly good reason. :wink:

EDIT: sorry guys, can’t get the spoiler to work for image, so it takes up the entire post… :pensive:

EDIT2: I also tried my other logins. “xamino” still returns the “please purchase” text. And the password and username are valid.

1 Like

What does the download / access page tell you ?

For “xamino” (password 1) (this account): negative, “wrong” old email address. (Changing email doesn’t work because my @gmail email which I used for the Kickstarter is tied to the xamino1 / 2 account).

For “xamino1”: can’t log in, I believe Keith passivized that account as a fix so that I could log back in to “xamino”.

For “xamino2” (password 2): positive, correct email address @gmail.

What I think is happening: xamino2 authenticates successfully but redirects to xamino, which means the email address doesn’t match when Battlescape checks the authentication. Happy to continue this in a thread / PM. Keith has the password to xamino2 if you want to try it.

Thanks for looking into it (again :stuck_out_tongue: )!

1 Like

Sure, I’ll see with Keith. It doesn’t make sense to me though, because the Access page uses the same sql request than the login through the game launcher. In fact, the entire reason I bothered with the access page was to verify that logging in via the launcher would work. But we must be doing something different somewhere.