Running infinity battlescape got me VCRUNTIME140_1.dll error

#1

Running infinity battlescape got me VCRUNTIME140_1.dll error after my first download and immediately after pressing play button once installed.

Any ideas please ?

#2

The error was that the dll was not found.

#3

Can you post / PM the install logs (INovaeInstaller_xxx.log ) located in C:\Users\XXX\AppData\Local\Temp\ ?

After you’ve done that, you can try to install the Visual Studio 2015-2019 x64 runtime from Microsoft: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

.; and that you fix it. Thank you :slight_smile:

#5

Reading version information from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\version’.
Reading features from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\Features’.
Reading components from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\Components’.
Reading installation location from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\installdir’.
Installation location: ‘C:\Program Files’
Reading installation location from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\level’.
Installation level: 100
Reading primary executable path from ‘C:\Program Files\INovaeInstallerRegistry\Products\0\installdir’.
Primary executable path: ‘C:\Program Files’
Product registry with root ‘C:\Program Files\INovaeInstallerRegistry\Products\0’ valid installation state confirmed.
Environment Information

Date: Tuesday, June 16, 2020 4:01:33 PM UTC
OS: Microsoft Windows NT 10.0.18362.0
.NET Framework Version: v4.0.30319
LocalApplicationData: ‘C:\Users\Jas\AppData\Local’
ProgramFiles: ‘C:\Program Files’
StartMenu: ‘C:\Users\Jas\AppData\Roaming\Microsoft\Windows\Start Menu’
CommonStartMenu: ‘C:\ProgramData\Microsoft\Windows\Start Menu’
TempPath: ‘C:\Users\Jas\AppData\Local\Temp’
InstallationRuntimeState: Installed
InstallationHive: Machine
InstallationVersion: 0.1.20.0
Is64BitOperatingSystem: True
Is64BitProcess: True
ProcessorCount: 4
HasShutdownStarted: False
CurrentAssemblyName: INovae.Installation, Version=1.0.15.0, Culture=neutral, PublicKeyToken=8ea5af5e5345540a
CurrentAssemblyLocation: ‘C:\Users\Jas\AppData\Local\Temp\INovaeInstaller_15e5a8c0b00e0\INovae.Installation.dll’
EntryAssemblyName: INovaeInstall, Version=0.1.20.0, Culture=neutral, PublicKeyToken=21cfd02acae3b790
EntryAssemblyLocation: ‘C:\Users\Jas\AppData\Local\Temp\INovaeInstaller_15e5a8c0b00e0\INovaeInstall.exe’
CommandLine: C:\Users\Jas\AppData\Local\Temp\INovaeInstaller_15e5a8c0b00e0\INovaeInstall.exe
CurrentDirectory: ‘C:\Users\Jas\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\TempState\Downloads’
UserInteractive: True
UserName: Jas
IsElevated: False
ImpersonationLevel: None
IsAnonymous: False
IsGuest: False
IsSystem: False
IsAuthenticated: True
Pending Reboot: False

Reading manifest for product 1 at path ‘C:\Program Files\INovaeInstallerRegistry\Products\1\PackageCache_0.1.21.0_.ind’…
Header Version: 2
Header Flags: NoFileData
Engine Version: 3
Target Platform: WindowsPC
CanMoveOrDeletePackage: False
AutoLaunchOverride:
Reading features from ‘C:\Users\Jas\AppData\Local\INovaeInstallerRegistry\Products\1\Features’.
Reading components from ‘C:\Users\Jas\AppData\Local\INovaeInstallerRegistry\Products\1\Components’.
Product registry with root ‘C:\Users\Jas\AppData\Local\INovaeInstallerRegistry\Products\1’ invalid installation state detected.
Reading version information from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\version’.
Reading features from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\Features’.
Reading components from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\Components’.
Reading installation location from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\installdir’.
Installation location: ‘C:\Program Files’
Reading installation location from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\level’.
Installation level: 100
Reading primary executable path from ‘C:\Program Files\INovaeInstallerRegistry\Products\1\installdir’.
Primary executable path: ‘C:\Program Files’
Product registry with root ‘C:\Program Files\INovaeInstallerRegistry\Products\1’ valid installation state confirmed.
The installation package manifest has been loaded.

#9

Two of the logs are two big to post here

#10

The two big ones are the ones needed :slight_smile: Try to compress them as a .zip or .rar instead. You should probably remove your previous posts, as they’re unrelated to your problem ( they’re the logs about the installer and the launcher, not the game itself ).

#11

Ok, I will try zip them and PM them maybe this evening.
The install from the link did fix the problem however.