Repair? problem

#1

Launcher where there usualy says update/start game or something, now says repair.

Here is the log:

https://files.fm/u/vhuxf6t3

#2

Do you have any other installation logs? It looks like your installation or upgrade was somehow corrupted and the log you posted is for a failed attempt at repairing the installation. Unfortunately, to fix this, you’ll have to clean it up manually. If you tried to install the game to its default installation location here’s what you have to do:

  1. Delete C:\Program Files\I-Novae Studios\Battlescape
  2. Delete C:\Program Files\INovaeInstallerRegistry\Products\2
  3. Run the launcher and try installing again
#3

Hi again

I ran 0.2.9 just before. 0.3.0. But when I went to install it, I dont quite remember what happened but I think I stopped the installer. Then later it said I have to repair it. Then it said it cant repair it. I tried cleaning up manually but nothing. Every time I do a clean install of the laucher it just says repair and then it cant repair it.

#4

I cant find this.

Also, I have a bunch of logs that the game made.

#5

Now I cant even install launcher.

Latest log file.

#6

Ok, a couple of people have run into this problem and I actually briefly ran into it myself last night. Unfortunately I wasn’t able to reproduce it again however I have an idea of what could be going on. I’m going to release a patch tomorrow and you’ll need to follow my previous instructions from above:

and try again once the patch is available (I’ll post here after it’s been made available). At the very least, if it continues to fail, it should give me a much better idea of what’s going on.

#7

Ok the new patch is up. Whenever you have a moment try it out and let me know what happens. If you encounter a problem again please post the log - I’ve added some additional logging info that should help us nail down the problem.

1 Like
#8

Trying launcher install
Launcher install failed
Log file created: (After checking log a while later, Im not sure which one was created at for this perticular point as I have severel logs)
https://ufile.io/w58g1 INovaeInstaller_ElevatedChildProcessConnection_13424.log (Created 23/06/2018 00:01)
https://ufile.io/87ks0 INovaeInstaller_1_88D5D88BBE3DB6AD.log (Created 23/06/2018 00:02)
https://ufile.io/lkv0u INovaeInstaller_ElevatedChildProcessConnection_6604.log (Created 23/06/2018 00:09)
https://ufile.io/nysxd INovaeInstaller_1_88D5D88CBD48E892.log (Created 23/06/2018 00:09)
https://ufile.io/60ob8 INovaeInstaller_ElevatedChildProcessConnection_7088.log (Created 23/06/2018 00:11)
https://ufile.io/139ww INovaeInstaller_silent_fail_174_7088.log (Created 23/06/2018 00:11)

Found out this folder was hidden: C:\Program Files\INovaeInstallerRegistry
Changed to show hidden files in folder prefrences
Deleted now: C:\Program Files\INovaeInstallerRegistry
Trying launcher again
Installation of launcher successfull
Started launcher
Launcher started
Install button visable
Going on with installation
It says “installation has failed”
New log file created: INovaeInstaller_2_88D5D88D04C7C113.log https://ufile.io/qq6zi

#9

Quick answer, going through the logs: you do not have enough disk space, probably on C. Even if you try to install the game on D:, it still needs to get unpacked in the temporary folder in C, so it probably requires 5 to 10 GB+ available on C. Keith can elaborate/confirm this ( I’m not the expert on installation issues ). IIRC the installer lacks more explicit warnings/messages when an error happens, like lack of disk space. Try to clean up some space in C, it might solve your issue.

#10

Yea, space on C: was problem. I just installed 0.3.0 without problems. Still, this is something you guys will have to fix in the future. If a player wants to install a game on drive where he has space, all (or most) of game should go in that folder or drive. This is one of the reasons why you ask players where they want the game installed.

Still, I kinda understand the complexity of problems you will encounter with the game. Ever since I read that World of Warcraft, a game that has by far one of the smoothest installs, needs to make 120 different versions of the game for every patch they make, I appriciate every install from a game that doesnt couses huge problems.

Then I understood why devs like to make games for PS or XBOX. One system.

Ok, time to try out alpha. Have nice weekend. Thanks for the support.

#11

To be honest I’m not sure a fix is really needed. We ask Windows to give us an official temporary place to unpack files needed during the installation. Windows gave us back a path on your C. If disk space is an issue, you can change the temporary files location to another drive ( see https://www.howtogeek.com/285710/how-to-move-windows-temporary-folders-to-another-drive/ for example ).

Disk space calculation is probably under-estimated somewhere and error messages aren’t clear enough or well communicated to the user. Keith is aware of these issues and will iterate/fix them over time.

#12

Never ask users to do anything. People just want to press play and have fun. Reason why consoles are so popular.

#13

Not everyone shares that view to be honest. If some software doesn’t let me pick the install location, I’m not installing it. :joy:

2 Likes
#14

Clean up your C drives folks, especially if they are SSDs, your SSD should never be more than 75% full or else you will start getting shitty performance, google it it’s all over the internet.

#15

can you actually change the inovaeinstallerregistry’s location? So far from what i understand that isnt possible and that folder is often sitting with several gbs.

#16

Is there a reason you can’t use the installation drive selected by the user as the location to unpack the files? Doing that might save you from answering this same question many times in the future.

1 Like
#17

That is the location where the files are unpacked. The problem is that the package cache contains packed files and currently the entire package is cached so that offline repair operations can be performed. The reason for this is that it was simply expedient at the time. Realistically, the installer only needs the uninstall instructions and could re-download the original package for repair operations if need be however I simply haven’t gotten around to implementing it yet. While this won’t completely resolve issues with disk space it’ll reduce the minimum impact on the C:\ drive from ~3gb to a few hundred kb.