Everything is blue

#1

Hi everyone. I’ve just downloaded and installed the beta and everything is blue. All the textures bar the background to space. I was wondering if anyone else has encountered this issue and if there’s an easy fix?

Extra info:
I installed the game onto a secondary drive (not sure if this is the problem).
I have a GTX980 and 16Gb RAM (all drivers up to date).
I have tried the game in exclusive full screen and borderless window with extreme and high settings.

#2

#3

Hua. . . that’s interesting. Texture corruption perhaps? I suggest @INovaeFlavien might be the only person who’d have an idea what’s up. Got any bug reports generated or anything in the meantime though?

#4

Does that happen in high too ? It seems something strange is going on with the 980s. Anarckos reported the same issue last week, and coincidentally (or more likely not) he’s also on a 980. But he said that switching from extreme to high fixed it for him. Try in high, or if it still doesn’t work, in medium level.

To be honest I have no idea what is going on. But I would be interested to know if anybody else had the same problem, and if you did, what video card do you have. Maybe it happens on 980s only ? Maybe a driver issue ? Could very well be related to the amounts of VRAM used. Or just an engine bug. In that last case, figuring out is gonna be tricky, not gonna lie.

#5

I had the blue textures too when I tried to run it on “Extreme”. I have a Nvidia 1080Ti with 11GB RAM. On “High” there seems to be no problem.

But as I’m running IBS through wine on linux I don’t know how comparable my bugs / experiences are.

Greets, DreamKeys

1 Like
#6

Its smurfs I tell ya. Braine and Astral Smurfs spreading the blue!

#7

So, 980 and 1080 so far. Does anybody have the issue on an AMD card ?

#8

If it helps, my 1060 seems fine! :slight_smile:

#9

First go on high I thought I had the same issue but it appears, I was just next to the gas giant :joy:. It seems to work fine on high now. Extreme still generates the same problem.

#10

Allright, so I’ll update my question. It seems at the moment it only happens on Nvidia cards and in EXTREME. Does anybody have the issue on AMD cards, or on NVidia cards in high or lower ?

1 Like
#11

Hi Flavien, I did some more EXTREME testing :wink:

The blue effect only happens in space! If there’s an atmosphere and I’m near the surface everything renders correctly.

EDIT: The blue effect starts at about 15km altitude on Cinder, flying below that will show everything normal. Going above turns blue mode on, and the cloud / dust effect vanishes. Also the space particles get lost, they simple don’t show. They aren’t dark like in a shadow, they just disappear.

The gas giant gets it’s blue look only if I approach it closely, it’s distance based and will start as a growing circle from the planets center. From afar it has a dark, dull look. The moons will look blue from any distance.

But in space I get this lovely effect …

… what an amazing view :grin:

And back to some ground base … :heart_eyes:

Logfile

DreamKeys

#12

Interesting. Implying it could be atmospheres-rendering related.

Please try the following ( but make sure you backup your files first ! ):

Edit the .xml files located in C:\Program Files\I-Novae Studios\Battlescape\Dev\Config\Planets2 ( or wherever you installed the game ).

For each planet ( like Gaian.xml ), find the CClientPlanetComponent component, and change:

<Atmosphere State="true" >

to

<Atmosphere State="false" >

Run the game and see if you still get that blue filter effect. Thanks.

#13

Cinder without atmosphere is interesting … But, the effect still happens :neutral_face:

Going up past 15-18km it’s renders everything blue, the HDR even reacts to it and adjusts the brightness. Going down it takes longer to get back to normal. I mostly have to be below 5km to get normal mode back.

#14

Hmm okay, so not atmosphere related. Next suspect would be IBL ( the cube map used for indirect lighting ). But it might need to wait for the next patch for further tests.

1 Like
#15

Yeah, might be something related to the lighting, sometimes even in space there are periods of normal colors. The blue might be painted over the normal textures and the HDR just darkens them as the blue is just full brightness (1.0). I had one angle in space looking back as I was approaching Aresthia in warp where I could see the normal ship colors underneath.

#16

Oh, do you want me to hop on and test this? I haven’t started the game in a week or so. But I’m running 1070 TI, so if it helps you get data I will.

#17

If you grab patch 0.4.4.1 you’ll see in the launcher dialog a new graphic setting quality option called “custom [debug]”. Select it.

In the mean time, go on your hard drive where the game got installed and edit ClientConfig.xml ( ex.: C:\Program Files\I-Novae Studios\Battlescape\Dev\ClientConfig.xml ). Make sure you keep a backup copy of the file, and make sure you edit the file with administrative privileges, otherwise your changes might get ignored by the system ( verify the file date has changed after you modified it ). It’ll be fine if you installed the game on a custom drive, but in the default C:\Program Files, you need admin rights to edit files.

At the bottom of ClientConfig.xml you’ll see a bunch of quality settings:

    <TextureQuality>2</TextureQuality>
    <LightingQuality>2</LightingQuality>
    <ShadowQuality>2</ShadowQuality>
    <GeometryQuality>2</GeometryQuality>
    <AntiAliasingQuality>1</AntiAliasingQuality>
    <TerrainQuality>1</TerrainQuality>
    <PlanetsQuality>1</PlanetsQuality>

Ignore AntiAliasing quality ( keep it to 1 no matter what, higher values are for experimental temporal AA which isn’t working yet ).

The values range from 0 to 3, 0 being for lowest and 3 for extreme. As you can see you can change the parameters independently for each category, whereas in the launcher dialog it overrides all these values and uses the same value for everything.

Since the problem seems to happen in “Extreme” mode, the idea is to change these categories to 3 one by one. Only do one change at a time, test the game, and see which one is causing the blue-filter glitch.

There is a good chance it’ll be related to LightingQuality, but it has to be confirmed.

Let me know the results once you do the tests, thanks !

4 Likes
#18

Short answer: Comfirmed :smiley:

Longer one:

I switched everything to 3 on it’s own and left AntiAliasingQuality always on 1.

TextureQuality > 3 ... OK
LightingQuality > 3 ... BLUE
ShadowQuality > 3 ... OK
GeometryQuality > 3 ... OK
TerrainQuality > 3 ... OK
PlanetsQuality > 3 ... OK

The last test was everything except LightingQuality on 3 … OK, no blue :sunglasses:

DreamKeys

3 Likes