Blank page after login

Every time I login, the website came to a blank page, no matter how I reflash (F5).

I have to re-type the URL, than it’s working.

Happens to me also, I login using Google+, once successful it opens as a blank page. If we want to be HTML technical. Last time it added a GET parameter ‘invalidatecache’.

It isn’t really a blank page, it returns a ‘500 Internal server error’.

I’m assuming this is only for login from the forums page. If you go direct to the main site and login that way do you have the same problem?

No. It logins onto the main site without problems.

Just to make sure I understand you correctly login from the main site works, so only login from the forums doesn’t?

Yes. (Adding extra characters to please the discourse forum gods)

1 Like

Yes, login from main site works fine.

BTW, you don’t have to use https everywhere. It will increase the server load and slow down page loading…

Just use https on some exceptional cases, such as login, payment etc…

Your user account will eventually be tied to our e-commerce portal and therefore it’s important to use https everywhere.

Hi, you need a URL to link the main site from this forum. :smile:

Yeah I know, it’s on the todo list :\

Both of my friends that tried signing up to the forums have this exact same problem.

@Freeman @Pendrokar do I understand correctly that you were able to work around it? My friend cant seem to see the forum once logged in no matter what he tries.

Which browsers are they using? Can you PM me their username’s?

One spent a while trying to get it to work last night, though he apparently only has Chrome installed on his computer and it didn’t work on his phone browser either. The other I’m fairly sure tried it on multiple browsers (Chrome + IE I think) plus his tablet. When they come online to talk to I’ll check that this is accurate / get more details.

PM sent, thank you for looking into this.

Well the workaround was just to open the forum URL manually, as (even with the error) the user should be already be logged in. But Keith fixed this problem at the start of year 2014. This might be a different issue.

Yes, it would seem that while its the same issue the cause is different.

I found a similar problem discussed on discourses own forum, though again probably with a different cause. And another small thing I forgot to mention earlier: I asked one of them to log into the demo forum on discourse’s site to see if they got the same result, but it all worked fine.

Edit: Ok, I was already quite sure that the problem was with new accounts but decided to create a 2nd account of my own to test the theory, same problem occurs (@The_Sane_Test) . Hope this helps / narrows down the search for the problem.

Server Error: [missing {{code}} value]
while trying to load /users/the_sane_test.json
Something went wrong.

On topic; forum redirects to the main inovae site when logging in with a google account, then redirects back to the forum.

This should be fixed now, please let me know if anyone is still experiencing this problem!

It still redirects to the main site when you click login…

I think he was referring to the issue that the topic is about. Redirecting to the main page isn’t exactly an issue. Perhaps inefficient, but doesn’t get in the way.

Oh, and thanks Keith! :smile: