X52 Pro Hotas, not working

#1

I’ve set this as the default controller in the launcher, but once in game I cant get my x52 to work. Any advice please! Do I have to toggle it on in game?

#2

Have you setup the keybindings in the launcher menu?
You also have to switch to direct control mode once in game by pressing f4.

2 Likes
#3

Most importantly press f4.

Also helpful advice:

https://forums.inovaestudios.com/t/joystick-shippitch-axis/8232/5?u=playbenni

3 Likes
Press [Space] to continue? Hotas fails to operate
#4

Thanks, managed to get it working. Had to bind both mouse and hotas pitch/yaw controls to “addCursor” rather than “setcursor”

3 Likes
#5

It’s natural for us to pay respects. I also press F.

3 Likes
#6

My X52 pro is not working at all, the game does not detect it, and I can’t set it up in the options, neither axes, nor buttons. Is there anything I’m missing? Switching to direct controls with F4 does not turn it on.

1 Like
#7

Its a new bug because of steam capturing the devices.
The devs want to fix that bug asap but they have to sleep first.
You can try to start the game from the exe in the games folder. For some people that worked.

1 Like
#8
#9

A Workaround has been found on the discord concerning the issue of the game not detecting the controller at all:

TheCoachToday at 2:01 PM
Steam HOTAS fix posted by @Sully and confirmed by others:
"If folks are still having issues with hotas/joysticks being recognized someone named HonO posted a link to this through Steam. I’m working so can’t test it but it looks like it might do the trick: https://support.rocketleague.com/hc/en-us/articles/360022354994-How-do-I-Disable-Steam-Controller-Configuration-

There’s also this: Right click on Infinity Battlescape in your Library, choose Properties.

Under the first tab - General
At the bottom, Steam Input Per-Game Setting (Requires restart of game)
Choose Forced Off"

1 Like