Not Detecting HOTAS Joystick or Thruster

#1

I just bought the game on Steam.

IB is not detecting my joystick as far as I can tell (Thrustmaster Warthog). As a result, I am unable to map to it. I have tried plugging in\out the joystick with no luck. Help?

#2

I don’t know at what stage is the HOTAS detection implementation in in-game settings for controls binding. Actually, it must be fully implemented… But, you can try to use the profile for your Warthog from this post: Hotas/Joystick controls feedback thread and maybe it will just_work™

#3

I dropped that file in with all the rest of the profiles and still no go. The issue seems to be that the game does not detect my Warthog controller. I am not using JoystickCurves or anything weird, just standard Microsoft drivers.

BTW, I am using Windows 10.

#4

There was a bug discovered just a few hours ago that is related with the game running over Steam. Apparently Steam captures some input devices and thus the game can’t see and use them.
The devs are working on resolving the issue.

If you got the game trough Kickstarter, Indiegogo or directly from I-Novae, then you can use the I-Novae launcher in the meantime. The porblem does not show up there.

Keith is working on also allowing people who bought the game trough steam to use the I-Novae Launcher … but acording to discord messages it’s not as easy to implement.

X52 Pro Hotas, not working
#5

Sounds like this is the issue. I will wait for the fix. Thanks for the info!

PS - It would be great if the devs could confirm that JoystickCurves is okay to use with IB. I’d like to reinstall it. :slight_smile:

#6

Could you describe its function? Does it create a virtual joystick you are using or does it work in another way?

#7

Well, I am not too technical. It says “Application works in the middle between physical and virtual joystick”. You can set sensitivity curves (I use a psychometric function). Makes making fine adjustments with the jstick easier. It’s a “must have” in Elite Dangerous I think.

https://www.xedocproject.com/joystickcurves.html

Might be redundant with what is already available in IB. But I bet a lot of people will have it installed especially if they are coming from Elite Dangerous to IB.

#8

I myself use a virtual Joystick for different reasons and there’s no problem there.
As long as you don’t read data from the game in order to cheat I think there is no issue with any third party program that adjusts curves and other things.

I see there’s an input and output device with the output generally going to a virtual joystick device. No problem there. Other users even use custom made controllers.

Feel free to use it and have fun. :grinning:
(Once the bug is fixed of course. Hehe)

#9

No cheating. I wouldn’t even know how.

#10

Workaround has been found on discord:

TheCoachToday at 2:01 PM
Steam HOTAS fix posted by @Sully and confirmed by others:
"If folks are still having issues with hotas/joysticks being recognized someone named HonO posted a link to this through Steam. I’m working so can’t test it but it looks like it might do the trick: https://support.rocketleague.com/hc/en-us/articles/360022354994-How-do-I-Disable-Steam-Controller-Configuration-

There’s also this: Right click on Infinity Battlescape in your Library, choose Properties.

Under the first tab - General
At the bottom, Steam Input Per-Game Setting (Requires restart of game)
Choose Forced Off"

2 Likes
pinned globally #11
#12

Hi Infinity Battlescape CMDRs

I’m trying to use my set up : VKB gladiator as joy and T.Flight Hotas X as throttle
Both joy are detected, everything works fine except for : yaw and pitch (VKB Gladiator)
I configure them in options/keybindings, it’s detected but not working ingame. Only the mouse is abble to perform these two maneuvers !

Strangely, roll is fine

Help !

#13

The “Forced Off” option works for me. I restarted Steam (and therefore also the game, of course) and had to assign the forced input devices (0 for joystick and 1 for throttle). I can now map my stick and throttle. :slight_smile:

#14

Just a heads up all some people are having issues with keybindings in the main menu. Doing your keybindings from within the game seems to resolve this problem.

#15

Press f4 in the game to Switch to direct control mode. Or assign the axis to target cursor shipyaw and ship pitch.

#17

We have fixed the problems in question. A patch will be released within an hour or 2 as we’re still fixing a few other issues that have popped up. You will need to have restarted your Steam client after the time of this writing for the full patch to go into effect. Thanks all for your patience!

3 Likes
Feedback after first day of play
#18

Does the game work with Trackir5? I just bought game in steam and it doesn’t recognize it by default. Can it be mapped manually?

#19

We do not officially support TrackIR however a number of players have gotten it working by binding it to an axis in the game. I recommend you ask in our Discord or start a separate thread and someone should be able to help you in fairly short order.

unpinned #20
#21

Actually we already have a thread: Trackir and VR?