Launcher Initialization error

#1

Hello, after years and years of following this software if finally bought into it. now im getting an error message when i try to run the launcher. its an “I-Novae Launcher Initialization error” has anyone else ever had this? i tried manually deleting it and reinstalling but no luck. thanks.

#2

I just responded to you in another thread but if you’re able to join our Discord while I’m around I can help you directly.

#3

ok, so the launcher is up and running, tried to run the game today after work but it wont run. the mouse icon shows loading for a second but thats it. or is the server not up full time maybe?

#4

It sounds like it might simply be failing to launch, maybe a dependency / DLL issue ? Do you have a log file ? They should be located in C:\Users\XXX\Documents\I-Novae Studios\Infinity Battlescape\Logs

#5

Yeah that’s how Keith helped me get the launcher running, the installation never added that file.
So we made it manually. But now I double checked and all those files are there but no “logs” at the end

#6

Just Tried a full reinstall. still no luck. when i install the launcher it still doesnt make the user path file.
had to make it manually again. just wont run. HELP!!! lol

#7

Have you tried deleting all Inovae related folders and files before trying a fresh install?

go to and delete all inovae folders in:
C:\Program Files (2 folders)

C:\Users\USERNAME\AppData\Local (2 folders)

Best restart before deleting and restart afterwards
Afterwards try a fresh install.

Just to be safe download the installation exe from the website again to make a new install.

#8

Deleting and reinstalling won’t fix the problem.

The game needs access to the documents path, period. That’s where it writes a bunch of config files for settings, profiles, logs, etc… So you have to figure out why an app wouldn’t have write access to this folder.

The first thing to do would be to check folder security / access permissions, for all folders in the path ( C:\Users\XXXX\Documents\I-Novae Studios ). IIRC in your case XXXX = admin, so maybe for some reason the launcher or the game do not have access to these folders. I can replicate this problem locally on my hard drive, by right-clicking on a folder -> Properties -> Security -> Modify and then refuse all access.

Another thing you can try is to execute the launcher or game as an admin.

Finally, the last solution which should hopefully fix it: create a secondary windows user account with a different username, and install the launcher/game from that account.

It is honestly mind-boggling to us that an app wouldn’t have access to the My Documents folder. Its sole purpose is for apps to write config and setting files. That Windows is refusing access to this folder is completely defeating the purpose of its existence.

1 Like
#9

yeah i tried all of those a few times.

#10

ok yeah this makes sense. it has to be a permissions problem… the thing is i install games all the time and never have this problem. ill try out what youve said! thanks. Im pumped to try this… ive been following since the tech demo i dont know how many years ago.

#11

OK the second user account worked. i checked all the permissions and they seem the same… not sure what the heck is going on. thanks Flavien, you’re a genius.

1 Like