Getting an error for posting with a legacy account

Testing posts

I have a legacy account and when I still get the error where it sends me to the “” page.

In addition to that bug when I attempt to post I always get the following error:

“Unknown error saving post, try again. Error: 422 error”

This occurs for any posts and private messages I attempt to send.

So far I have been unable to post since these forums came up. I finally tested to see if making a new account fixes it and it clearly does. It would be nice to be able to post on my original account though.

Hopefully a fix for this can be found

What is your other account?

I’ve been getting to the invalidatecache page whenever I try to log in, but after pressing back a few times to get to the main forum page, and refreshing, I am logged in regardless.

If you get to the Invalidatecache site just “load” the page. For some reason it won’t load at that point for … pretty much everyone. If Invalidatecache would reload itself the forum would work fine from my perspective.

The invalidatecache was created to workaround a bug in Discourse. They fixed the bug and now invalidatecache is a bug lol. I’ll fix it soon.

Lol. So I just proposed a workaround for a Bug that in fact is itself a workaround. Funny.

The other account is TheCookieMonsterr.

Thanks you all for replying so quickly

Have any ideas? I try and testpost every so often and I’m still unable to

I haven’t had a chance to look at it yet, I’ll try to get to it sometime this weekend.

Okay thank you. No rush! Work on battlescape or the KS is more important than my account so I can wait.

I just logged in with my old account and it was derping up something serious. But I think it’s okay now.

@TestAccount123 I took a look at this issue last night and so far I don’t see anything wrong with your other account. Currently I’m quite puzzled as to what could be the problem. I’m working on updating the forums to the latest Discourse build this weekend so hopefully whatever the issue is they’ve already fixed it.

Very weird. I’ve always had a nasty habit of breaking things. Well, I just attempted to post again and I’m still getting the issue. I was thinking it could be noscript or adblocker but I tried disabled both addons to see if it made any difference and they do not. I will try again this weekend to see if the updated build changes anything. If all else fails I’ll just make a real new account and start over

Thanks for checking up on it

Which browser are you using out of curiosity?

I run mozilla. Now that I think about it, I do run an older version on both my laptop and my pc so that could be it…I will try using an updated browser in a bit and see if that changes anything.

I attempted to post with the other account on chrome(which I am currently using) and was still unsuccessful.

The error was almost identical with the addition of “OK”:
Unknown error saving post, try again. Error: 422 OK

Ok I’ve updated the version of Discourse we’re using, please try again.

Logging in, for me, still goes to a blank white screen but the “invalidatecache” bit has disappeared from the URL. Clicking bookmark again still works (evidently).

Man, debugging is awesome, right?

I still haven’t been able to log in with my legacy account, last time I tried it bugged out and I couldn’t log in with this account either for a couple of days.

No error screens, just a major slowdown and when the forum page finaly came up I wasnt logged in. Subsequent attempts to log in would make it seem like I was logged in on the homepage but not in the forums.

I thought I replied to this a week ago, apologies. I still get nothing. If I make a new account is there any way to link the legacy aspect of my old account to the new one? Either way starting a new one just seems simpler at this point.