Can't play Beta

#1

Is there a secret to playing the Beta? I’m a Planetary Supporter and I should have access.

When I start it, Launcher 0.1.16.0 starts, I click Play, configure the Prototype with resolution, controls, etc. Then I hit Launch Game and I get the loading screen (static cockpit view) with the top-right spinner. After a while I see a full-screen animated planet and the music plays (I see “0.4.1.0 BETA” in the bottom-left corner). After hitting a key it goes back to the static screen and after about 15s a little dialog pops up saying “Connection Lost…” and after clicking OK everything exits.

I’ve tried multiple times over the last few weeks at various times of the day, but always the same failure.

Any ideas?

  • Clutchplate
1 Like
#2

No, that’s obviously not normal. In which country are you located ?

Also, try to find the latest log file ( C:\Users\XXX\Documents\I-Novae Studios\Infinity Battlescape\Logs ) and send it to me by private message, and I’ll have investigate to see if there’s something unusual going on, thank you.

Finally, I’d recommend to have a look at your anti-virus or proxy settings ( assuming you have one ), maybe it refuses the connection. Could also be a router issue if you have one, the game needs outgoing port UDP 7778 to be opened.

Right after you get the 0.4.1.0 BETA " click to continue" screen is when it attempts to log in to the server. It seems like it fails to connect to the server, however the server has been up 24h/24, therefore it definitely sounds like something on your end is preventing you from establishing a connection.

1 Like
#3

I’m in the US. I’ll send you the latest log file.

1 Like
#4

Thanks. As I suspected, it’s a time out. Something is preventing a connection to the server. If I were you I’d check anti-virus, firewall and router settings (when applicable).

#5

I added the executables to the Firewall exceptions. Using Process Explorer, the only connection I see trying to be established is this:

UDP win8-devmain.kretzschmar.local:64313 * : *

That’s my local machine and no specific remote address, which is bound to fail. Does that seem right to you? I will check my router as well to allow port 7778 through, not sure that will help.

#6

That looks like it’s just listening for inbound UDP on that port which sounds totally normal but your router may need that port forwarded to your machine.

6 Likes
#7

Ahh, yes, you’re right. So maybe I need to use WireShark to see exactly what’s going on.

1 Like